Possible Connectivity Issues
Incident Report for Teckro
Resolved
This incident has been resolved.
Posted Jan 15, 2021 - 18:05 UTC
Investigating
Our automated systems have detected possible connectivity issues to our backend services.
Posted Jan 15, 2021 - 17:57 UTC
This incident affected: Teckro Mobile Application and Teckro Web Application.