Possible Connectivity Issues
Incident Report for Teckro
Resolved
This incident has been resolved.
Posted Mar 17, 2020 - 09:59 UTC
Investigating
Our automated systems have detected possible connectivity issues to our backend services.
Posted Mar 17, 2020 - 09:53 UTC
This incident affected: Teckro Mobile Application and Teckro Web Application.